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Welcome to SnagIt 
Thank you for your purchase of SnagIt. SnagIt is the premier application to use for all of your screen 
capturing needs. Whatever you can see on your screen, SnagIt will easily capture for your immediate use. 
Once you’ve taken your capture, SnagIt lets you edit, enhance, save, and use the capture for numerous tasks. 
 
This Getting Started Guide will quickly teach you the key concepts for using SnagIt. You will be guided in a 
simple step by step process through the following topics: 

• Getting familiar with SnagIt's main user interface and features. 
• Capturing with SnagIt. 
• Taking your First Capture. 
• Modifying your Capture Settings. 
• Working with Profiles. 
• Using Catalog Browser. 
• Using SnagIt Editor. 
• Using SnagIt Studio. 
• Exploring the most popular editing and special effects features. 

 
This guide is intended to provide you an excellent introduction to SnagIt. Please refer to the Online SnagIt 
Help file for a comprehensive explanation of all the features. 
 
We hope you enjoy SnagIt. 

 
This Getting Started Guide was created using SnagIt, SnagIt Editor, and SnagIt Studio. 
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SnagIt Overview 
SnagIt has an easy-to-use and intuitive interface. Below you will find a basic overview of the different 
components of the Normal view. Basically SnagIt is comprised of capture profiles in the Capture Profile 
pane on the left and the selected profile’s attributes in the Capture Settings pane on the right. Once you select 
a profile, simply click the Capture button.  
 

 
 
 
 
 

 

Capture Profiles in the left pane allow you 
to take a capture quickly. Capture profiles 
are a fast and powerful way to configure 
what you want to capture. All the capture 
settings you see in the Capture Settings 
pane make up one profile.  
 

Capture Settings in the right pane are 
updated when a profile is selected in the left 
pane. Customize a capture by making 
changes and then click the Capture button. 

 

 

 

 

 

 

 

 

 
 

Capture Button performs the capture. You 
can also use the default global hotkey which 
is <CTRL>+<Shift>+<P> on the the keyboard. 
 

Edit Tab gives access to companion editing 
applications and tools such as SnagIt Editor, 
SnagIt Studio, and Batch Conversion Wizard. 
  

Organize Tab gives access to companion 
applications used to organize your captures, 
such as Catalog Browser, Web Page Creator, 
and SnagIt Printer Capture. 
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 Capture Profile Properties will display 
in the form of a tool tip. Properties include 
such things as the hotkey, input, output, 
and filters. The capture mode is easily 
identified by the picture icon.  

Filters apply edits or special effects during the 
actual capture process. To access the filter options, 
choose Filter in the Capture Settings pane. Select 
desired option from the dropdown menu. Options 
will differ according to the capture mode selected. 

 Mode controls the way that SnagIt will 
capture information. This includes image, 
text, video, and Web captures.  
To change the mode, simply click on the 
desired mode button in the Capture 
Settings pane.  

Options are preferences that you can select that 
will further define how you want your capture to 
look or if you would like to preview your capture 
before it is sent to output. Options may include 
ability to capture cursor, set timer for delayed 
capture, capture multiple areas, etc. and will differ 
according to the Mode and Input selected. 

 Input allows you to choose what you want 
to capture. To access the input options, 
choose Input in the Capture Settings pane. 
Select desired option from the dropdown 
menu. Options will differ according to the 
capture mode selected. 

Save Profile allows you to save the current settings 
within the Capture Settings pane as a new capture 
profile. You also have the option to overwrite an 
existing profile that is currently selected. New 
capture profiles will display within My Captures in 
the Capture Profile pane.  

 Output allows you to choose what 
happens to the capture once it is taken.  To 
access the output options, choose Output 
in the Capture Settings pane. Select 
desired option from the dropdown menu. 
Options will differ according to the capture 
mode selected.  

Add New Profile Wizard allows you to create a 
new profile from “scratch” rather than modifying 
and saving an existing capture profile. The wizard 
walks you through choosing all capture settings. 
New capture profiles will display within My 
Captures in the Capture Profile pane. 
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Capturing with SnagIt 
The primary function of SnagIt is to capture data in their many different forms on your system.  
 
There are Five Different Capture Modes in SnagIt 

 

Image Capture 
 

SnagIt captures an image of your screen or any portion of it. You can capture 
images of any software application, DirectX games, from scanners, or anything 
else you see on your computer screen. Once captured, you can send the image to 
many outputs including a graphic file, the printer, e-mail, or even a web server. 

 

Text Capture 
 

SnagIt captures the text you see on the screen as editable, ASCII text. SnagIt 
can even save the text in tab delimited format so that it can be easily imported 
into spreadsheets or database applications for sorting and other manipulation. 

 

Video Capture 
 

SnagIt records any on-screen activity on your Windows desktop. Capture all 
your mouse movements and application action and save the video as an 
industry-standard AVI file. You can also use SnagIt to create time-lapse video 
of desktop activity over a period of time. 

 

Web Capture 
 

With Web Capture, you can simultaneously capture all the .png, .jpg and .gif 
images from a Web site. All you need to do is type in the Web site address. 
You can then choose the Web page link depth, which is the number of levels of 
directories from the root Web address to be included in the search.  

 

Printer Capture SnagIt captures anything you would normally send to a printer and spools it to 
an image file instead. You do this by printing to the SnagIt virtual printer from 
any Windows application. Printer Capture settings are accessed from the Tools 
> SnagIt Printer Capture Settings inside SnagIt. 

 
These are the Default Capture Profiles 
They are preconfigured for you so you can begin to take captures right away. The Capture Profiles have 
icons next to them to let you know which mode is being used.  

 
 

 
 
 
 
 

 
 
 
 
 
 

 

 
 
 
 
 

 

The Image Capture Profiles include region, 
window, scrolling window, menu, object, 
freehand, DirectX, and entire screen.  
 
 

The Text Capture Profile will capture text out 
of the window that you select, and save it to a 
text file. 
 
 
 
 

The Video Capture Profile will record a fixed 
region of the screen and save it to an AVI file.  
 
 
 
 
 

The Web Capture Profiles will prompt for a 
Web address to capture all images from a 
Website. The files will be saved to the SnagIt 
Catalog folder.  
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Below are just a few of over forty different ways SnagIt can capture.  
 

 
Screen: Capture everything that shows on your 
computer desktop including the cursor if desired. 

 

 
Rectangular Region: Capture a rectangular shape 
anywhere on your desktop.  

Window: Capture an application window, dialog box, 
window frame, etc.  

 

Scrolling Window: Capture the contents of a 
window, including the part not seen. 
 

Game (DirectX): Capture scenes from DirectX 
games or DirectX media players.   

 

Text: Capture text in tab delimited format to import 
into spreadsheets or database applications. 
 

 
Object: Capture a specific item on your computer 
desktop such as a button, icon, toolbar, etc.   

Menu: Capture dropdown and cascading menus 
from Windows programs.  
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Taking your First Capture 
Taking screen captures with SnagIt is simple. Just click on a Capture Profile in the left pane to select what 
you want to capture, then click the Capture button. The capture will be displayed within the Preview 
Window, allowing you to view, edit, and enhance your capture.   

 
Select Capture Profile. The Region to File profile is selected by default. When making any capture 
profile selection, the profile is highlighted by an orange bar.  

 
Click the Capture button to begin the capture. The window disappears and you see a crosshair 
cursor. Drag the crosshairs across the screen to capture a region then release.  

 

 Key Concepts 
About the Capture Profile: Many of the most common types of captures have been saved as Capture 
Profiles and are ready for you to use as soon as SnagIt is installed. Profiles contain a set of capture 
instructions including the mode, input and output settings, filters, and more. To choose a capture profile to 
work with, simply select the profile from the list and then click on the Capture button. 

The Different Capture Modes: The Mode controls the way that SnagIt will capture information. This 
includes the ability to take image, text, video, and Web captures. To choose 
another category or kind of capture, select the desired capture profile where the 
mode is indicated by the icon within the list.   
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Finish Capture. Click the Finish button to send the capture to the output. For easy reference, the 
output format is shown within the Finish button. In this example, the capture will be saved as a file.  

 
Save as File. In the Save As dialog box, enter the name of the file, select file format, choose OK.  

 

 Key Concepts 
Edit: You can edit your capture in any number of ways. For example, Crop allows you to select a region to 
save while trimming away the rest of the image. Use the Selection tool  to drag a region around the 
portion of the capture you want to save. Click on the Crop tool . 

Outputs Toolbar: Use the Preview Window’s various output options on the Outputs toolbar to send your 
capture to any number of outputs “on the fly.” For example, click on the Clipboard tool  to copy this 
capture to the Windows Clipboard. 
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Preview Window Overview 
Preview Window allows you to preview and edit a screen capture before it is saved to a file or inserted into 
your document or email. Choose from an array of professional quality effects to get just the right look.  
 

 Finish / Cancel Capture. Click Finish to 
send the capture to the output. The output 
type is given within the button for easy 
reference. Choose Cancel Capture to 
discard this capture.  

Drawing Tools. This is the drawing tools pane. 
Enable antialias to give a smooth look to your 
drawing lines. Enable drop shadow to give your 
drawing a 3D, professional look. Click on the 
color block to change the drawing tool’s color. 

 Output Options. On the Outputs toolbar, 
click on any tool to perform that output 
operation. Tool tips let you know what each 
tool is. Beneath the Outputs toolbar you 
will find another toolbar containing basic 
editing options such as Crop, Cut, Copy, 
and Paste.  

Enhancements. Use the Image, Colors, and 
Effects menu options to enhance your captures in 
an unlimited number of  ways. Let your 
imagination run wild and have fun creating!  
These enhancements are available in both Preview 
Window and SnagIt Editor.  
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Modifying your Capture Settings  
There will be times when you will want to take a capture and there is not an existing capture profile to suit 
your needs. Creating a new profile by modifying an existing one is simple and easy to do. Here’s how. 

 
Change Capture Profile. In the left 
pane, click A Window to File.   

Add a Filter. In the Capture Settings, choose 
Filters > Edge Effect > Drop Shadow Edge.  

 
Change Output. In the Capture 
Settings pane on the right, choose 
Output > Send Mail.  

 
Take Capture. Click the Capture button to begin 
capture. Move the rectangle around the screen to 
highlight a window. Click with mouse to capture.  

 

 Key Concepts 
Unsaved Profile: Once you change any of the settings for a capture profile, the Profile Name field within 
the Capture Settings pane changes to Unsaved. This alerts you to the fact that you have modified a profile.  
Important Note: If you select a new profile before saving, all of the changes to your settings will be lost.   

Save Profile: Save the new capture settings as a profile to use later. You can choose Save Profile > Save As 
New to create a new profile under My Profiles. Or, choose Overwrite to save as the current profile’s settings.  
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 Make a Selection. Choose a Selection tool  in the Properties box and drag an area on the 
capture. Choose Effect > Spotlight/Magnify. Select the desired Options and then click on OK. 

 
Finish to Send to Output. Click on the Finish button which will reflect the current output.  

 
Address Mail. You capture is automatically attached as a bitmap file in an email message. 
Address your message as desired and then click Send. 

 

 Key Concepts 
Undo/Redo: Don’t like what you just did? SnagIt gives you the power of an unlimited Undo/Redo feature. 
To undo your steps, click the Undo tool . Decide you liked that look after all? Click on the Redo tool .  

Spotlight Effect: For an interesting special effect, choose the Freehand selection tool and use this to 
outline an object in your capture. Apply the Spotlight/Magnify effect. 

Highlight Tool: With the Highlight tool , create focus on your capture using any color . 



Getting Started Guide SnagIt  

12  •  Working with Profiles www.techsmith.com 

Working with Profiles 
Once you change or modify any of the settings for a capture profile, the Profile Name field within the 
Capture Settings pane changes to Unsaved. Additionally, the orange frame around the capture profile 
changes to an empty frame. Choose Save Profile to save these settings as a new profile. If you do not save 
your new settings, once you choose another capture profile, your new settings will be lost.  

 

 

Select Capture Profile. In the Capture Profile pane, choose A Region to File capture profile. Notice 
that the capture settings are loaded into the Capture Settings pane on the right and the frame 
surrounding the capture profile is orange. Additionally, the name of the profile is shown in the 
Profile field under Capture Settings.  

  

 

Change Output Setting. In the Capture Settings pane, choose Output > Multiple Outputs. Notice at 
this time that the frame around the profile has gone away. And, the profile name in the Capture 
Settings pane has been changed to red and the word Unsaved, also in red, has been added next to the 
Profile label.  

 Save Profile. Click on the Save Profile button . The Save Profile 
dialog box displays. 
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Save as a New Profile. Within the Save Profile dialog box, click on the Save As New button.  

 
Choose a Name. The Save Profile As dialog box displays. A default name is entered for you. Enter a 
new name or do nothing to accept the default name. Add a hotkey if desired. Choose Save.  

 
Profile is Saved in My Profiles. Your new capture profile will now be stored under My Profiles 
group within the left pane.  

 
Capture Settings Display. Additionally, when the new profile is selected the settings are updated in 
the Capture Settings pane on the right.  

 

 Key Concepts 
Overwrite Existing Profile: Within the Save As dialog box, you have the choice to Overwrite the existing 
capture profile settings. If you choose to overwrite, then the settings that are connected with the profile in the 
current empty frame will be changed to match the new settings that you have selected.  

Using your New Capture Profile: New capture profiles are stored within My Profiles in the left pane. To 
use your new profile, click once on the profile to highlight it. Click the Capture button. Additionally, use 
SnagIt OneClick to access your basic and custom profiles or to open SnagIt and its companion applications, 
SnagIt Editor, SnagIt Studio, and Catalog Browser, all with just one click. Choose View > SnagIt OneClick.  

Add New Profile Wizard: Allows you to create a new profile from “scratch” rather than modifying and 
saving an existing capture profile. The wizard walks you through choosing all capture settings. New capture 
profiles will display within My Captures in the Capture Profile pane. 

Organizing your Profiles: You can change the order of your capture profiles within the Capture Profiles 
pane. Right-click on the left pane. Form the popup menu, choose Organize Profiles or select File > Organize 
Profiles. Use the various options to add a new group, move captures up or down within the list, or to add a 
hotkey. When finished organizing, click on Close. Your list will be updated.  
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Catalog Browser Overview 
SnagIt's Catalog Browser allows you to locate, view, and manage captures and multimedia files in thumbnail 
view. The Catalog Browser can view images, text, and .avi files. You can select multiple files to save, 
convert file formats, print, and email in batches.  

 
Toolbar. You can access several commonly used options from the toolbar such as the Web Page 
Creator or the Batch Conversion Wizard. Move the mouse across the toolbar to display the tool tips.  

 
Browser Area. Search and select the folder that contains your media files to update them to the 
thumbnail view frame. 

 View Thumbnails. Click on the Thumbnail View button  to see visual thumbnails. Click on the 

Detail View button  to see file details in browser format. 

 
Viewing Area. The thumbnails images or file details display in this area. The view displayed 
depends upon which view is selected in the toolbar.  

 
Preview. A larger view of the selected thumbnail displays in the Preview Area.  
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SnagIt Editor Overview 
The SnagIt Editor is a great way to edit a screen capture after it is saved to a file since Editor allows you to 
apply professional quality finishing touches to your images without having to take a capture. Editing options 
include flip, reverse, shear, rotate, crop, and cut. Adjust the color depth, add text, or view the frames of a 
video capture. Add custom edge effects such as drop shadow, torn or faded edges, and enhancements such as 
arrows, cursors, lines, text, and much more.  
You will see that SnagIt Editor is very similar in look and feel to the Preview Window. While they are very 
similar, notice the absence of the Finish and Cancel buttons.  

 
 

 

Open. Click Open to open an existing media 
file and display it within SnagIt Editor.  
Toolbar Options. On the toolbars, click on 
any tool to perform that operation. Tool tips 
let you know what each tool is. The toolbar 
contains output options as well as basic 
editing options such as Crop, Cut, Copy, and 
Paste. 

 
 
 

Drawing Tools. This is the drawing tools pane. 
Enable antialias to give a smooth look to your 
drawing lines. Enable drop shadow to give your 
drawing a 3D, professional look. Click on the 
color block to change the drawing tool’s color. 
Enhancements. Use the Image, Colors, and 
Effects menu options to enhance your captures in 
an unlimited number of ways.  
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SnagIt Studio 
SnagIt Studio provides true vector-based image markup of standard and custom shapes. Studio includes an 
expansive catalogue with useful annotation objects and shapes such as arrows, logos, callouts, text boxes, 
rubber stamps, captions, sticky notes and frames to help explain your images.  
You can easily add and re-position the catalog objects or create collections of custom drawing shapes. 
Images can be quickly overlapped to create a collage effect, or multiple images can be printed on a single 
page. Once an image has been modified, it can be saved as a Studio project for later changes.  

 
 

 

 

 

 

 

Toolbar Options. On the toolbars, click on 
any tool to perform that operation. Tool tips 
let you know what each tool is. Toolbars are 
enabled from the View menu.  

Catalogue. There are a number of standard 
catalogues delivered with SnagIt Studio. These 
contain Stamps, Shapes, Pointers, Clipart, 
Callouts, and Arrows. In addition, a blank 
catalogue called My Catalogue, can be used 
for storing your own, customized shapes.  

 
 

Drawing Tools. This is the drawing tools pane. 
Use these to add text, highlights, or shapes to your 
image. Click on the color block to change the 
drawing tool’s color. 
The Canvas is where you will design your project 
by adding elements of different types. Once your 
elements are on the canvas, each one can be 
customized by using the group, align, move to 
front or back, size, rotate, or edit bitmap features.  




